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1 Objectivos

Pretende-se com este trabalho de laboratório introduzir e familiarizar os alunos com as ferra-
mentas de CAD e placas de desenvolvimento da Xilinx que serão usadas na cadeira de CID/SID.

2 Introdução

Neste laboratório vão ser implementados dois circuitos de exemplo:

1. Circuito para colocar, de forma “aleatória”, o led da placa acesso ou apagado, cada vez
que se carrega no interruptor.

2. Circuito divisor de relógio para que, em conjunto com o circuito anterior, se possa controlar
se o led fica acesso ou apagado.

3 Projecto do 1o Circuito

O sistema de CAD utilizado para descrever e sintetizar o circuito é o WebPACK - Project
Navigator da Xilinx. Para começar a correr este programa click no ı́cone Project Navigator. Os
principais passos para criar um circuito descrito em VHDL são:

3.1 Criação do Projecto

1. Seleccione o menu File → New Project...

2. Na janela que aparece escolha um localização para o projecto numa directoria do disco
local (C:\tmp) e depois o nome que quer dar ao projecto (proj1). Em seguida certifique-se
que a propriedades do dispositivo têm os seguintes valores:

Property Name Value

Device Family Spartan2

Device xc2s200

Package pq208

Speed Grade -5

Design Flow XST VHDL
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3.2 Criação/Adição de Circuitos

1. Para adicionar um novo circuito ao projecto seleccione a opção Project → New Source...

2. No 1o passo (New) da janela que se abre escolha o tipo de ficheiro como VHDL Module
para a descrição do circuito em VHDL ou Schematic para descrição do circuito através
de esquemas. Note-se que num dado projecto podem existir ficheiros de vários tipos.
Introduza o nome do ficheiro a criar (cir1), que deve de ser igual ao nome da entidade
VHDL que vai ser descrita. Seleccione Next > para passar ao passo seguinte.

3. No 2o passo (Define VHDL Source) verifique se o nomes da entidade (Entity Name) e da
arquitectura (Architecture Name) do componente que vai descrever em VHDL estão cor-
rectos. Introduza o nome dos portos de entrada (botao e clk) e sáıda (led) do circuito,
as respectivas direcções (in, out ou inout). Para o portos que são vectores (buses) defina
também qual a posição do bit mais e menos significativo.
Note que estes dados apenas vão ser utilizados no template de VHDL que será apresen-
tado quando da criação do circuito pela primeira vez, podendo depois ser completamente
alterados através do editor de texto.
Seleccione Next > para passar ao passo seguinte.

4. No 3o passo (New Source Information) certifique-se que todos os dados introduzido estão
correctos e seleccione Finish para terminar a criação do novo ficheiro VHDL.

5. A janela criada do editor de texto permite alterar/completar o código VHDL do circuito.
Complete a descrição do circuito para obter a seguinte especificação VDHL:

library IEEE;
use IEEE. STD LOGIC 1164 . al l ;
use IEEE. STD LOGIC ARITH. al l ;
use IEEE. STD LOGIC UNSIGNED. al l ;

entity c i r1 is
port ( botao : in s t d l o g i c ;

led : out s t d l o g i c ;
c lk : in s t d l o g i c ) ;

end c i r1 ;

architecture Behavioral of c i r1 is
signal d , q : s t d l o g i c ;

begin
process ( c lk , botao )
begin −− process

i f c lk ’ event and c lk = ’ 1 ’ then
i f botao = ’ 1 ’ then

q <= d;
end i f ;

end i f ;
end process ;
d <= not q ;
led <= q ;

end Behavioral ;
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6. Após introduzir a descrição VHDL grave-a com File → Save.

3.3 Śıntese do Circuito

1. A janela do lado esquerdo (Processes for Current Source) apresenta os processos e ope-
rações que podem ser aplicadas ao circuito seleccionado. Para sintetizar o circuito faça um
duplo click em Synthesize. Se não ocorrerem erros durante o processo de śıntese um sinal
de executado aparece a verde. Se existirem erros ou avisos aparece uma cruz a vermelho
ou uma exclamação a amarelo, respectivamente. Neste caso deve ser verificado o relatório
do processo de śıntese na janela inferior, onde estão indicados os erros com uma marca
vermelha e os avisos com uma marca amarela. Se se fizer um duplo click nessa marca é
indicada no código VHDL a linha do respectivo erro ou aviso.

3.4 Simulação Comportamental do Circuito

A simulação do circuito só deve de ser feita depois de se garantir que a respectiva descrição
VHDL não apresenta erros e pode ser sintetizável pela ferramenta de śıntese.

3.4.1 Criação da Bancada de Teste

Para realizar a simulação do circuito é conveniente criar uma uma bancada de teste (testbench)
escrita em VHDL. Esta é a forma mais simples e normalizada de descrever os est́ımulos de simu-
lação e verificar o comportamento do circuito, pois consiste na utilização da própria linguagem
VHDL. Assim, deve ser criada um entidade de teste cuja arquitectura instancia o componente
a testar e gera o est́ımulos necessários à sua verificação.

1. Para adicionar uma bancada de teste ao projecto seleccione Project → Add Source...

2. No 1o passo (New) da janela que se abre escolha o tipo de ficheiro como VHDL TestBench.
Introduza o nome da bancada de teste a criar, em geral será igual ao nome do circuito
seguido de tb. Seleccione Next > para passar ao passo seguinte.

3. No 2a passo (Select) seleccione o nome do circuito (entidade) para o qual se vai criar a
bancada de teste. Seleccione Next > para passar ao passo seguinte.

4. No 3a passo (New Source Information) certifique-se que todos os dados introduzido estão
correctos e seleccione Finish para terminar a criação da nova bancada de teste em VHDL.

5. Na janela do editor de texto deve ser completada a bancada de teste do circuito com
as sequências de teste necessárias para verificar o correcto funcionamento do circuito.
Complete a descrição da bancada de teste do circuito para obter a seguinte especificação
VHDL1:

1Nota: o ficheiro com a especificação VHDL pode ser escrito utilizando qualquer editor de texto e depois
importado para o Project Navigator. Para isso, seleccione a opção Project → Add Source... ou Project → Add
Copy of Source... e depois importe o ficheiro de acordo com o tipo de VHDL descrito: Module, Package ou
TestBench.
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−−VHDL Test Bench Created from source f i l e c ir1 . vhd
−−
−− Notes : This t e s t be nc h has been a u t o m a t i c a l l y
−− generated using types s t d l o g i c and s t d l o g i c v e c t o r
−− for the ports of the unit under t e s t . Xi l inx
−− recommends that these types always be used for the
−− top−l e v e l I /O of a design in order to guarantee that
−− the t e s t b en ch w i l l bind c o r r e c t l y to the
−− post−implementation s imula t ion model .
−−
library i e e e ;
use i e e e . s t d l o g i c 1 1 6 4 . al l ;
use i e e e . numeric std . al l ;

entity testbench is
end testbench ;

architecture behavior of testbench is

component c i r1
port ( botao : in s t d l o g i c ;

c lk : in s t d l o g i c ;
led : out s t d l o g i c ) ;

end component ;

signal botao : s t d l o g i c ;
signal led : s t d l o g i c ;
signal c lk : s t d l o g i c ;

signal c lock : s t d l o g i c : = ’ 1 ’ ; −− i n i c i a l i z a c a o somente
−− v a l i d a para simulacao

begin

uut : c i r 1 port map(
botao => botao ,
led => led ,
c lk => c lk ) ;

−− ∗∗∗ Test Bench − User Defined Sect ion ∗∗∗
c lock <= not c lock after 10 ns ; −− T=20 ns => f =50 MHz
c lk <= clock ;
tb : process
begin

botao <= ’0’ after 10 ns , ’ 1 ’ after 350 ns ,
’ 0 ’ after 450 ns , ’ 1 ’ after 750 ns ,
’ 0 ’ after 930 ns ;

wait for 1000 ns ;
assert f a l s e report ”Fim da simulacao ” severity warning ;
wait ; −− w i l l wait f o re v e r

end process ;
−− ∗∗∗ End Test Bench − User Defined Sect ion ∗∗∗

END;
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6. Depois de gravada, a nova entidade VHDL (e respectivo ficheiro) aparece associada ao
circuito para qual o teste foi gerado.

3.4.2 Simulação da Bancada de Teste

1. Tendo a bancada de teste que se deseja simular seleccionada na janela Sources in Pro-
ject aparecem os tipos de simulação posśıveis que podem ser realizados com o simulador
ModelSim. Para realizar a simulação comportamental faça um duplo click em Simulate
Behavioral VHDL Model. Note que, o circuito que se vai simular é a bancada de teste que
por sua vez instancia o circuito o qual se pretende verificar o funcionamento.

2. Se não houver erros aparecem várias janelas do simulador. Verifique o resultado da simu-
lação na janela wave - default. Para ver toda a simulação faça View → Zoom → Zoom
Full. Tente perceber porque é que sáıda led fica com o valor constante U (Undefined).

3. Para re-simular o circuito com a sáıda q do flip-flop inicializada a um dado valor comece por
re-inicializar a simulação seleccionando na janela ModelSim XE a seguinte opção Simulate
→ Run → Restart... e depois seleccionando Restart na janela que aparece.

4. Na janela Structure seleccione o circuito onde o sinal q está definido, ou seja, seleccione o
circuito uut:cir1.

5. Na janela Signals aparecem todos os sinais do respectivo circuito. Seleccione o sinal q e
depois a opção do menu Edit → Force... para forçar um dado valor no sinal.

6. Na janela Force Selected Signals escolha o valor a forçar (por exemplo 1) e o tipo (Kind)
como Deposit.

7. Para simular o circuito por 1 us altere o tempo de simulação de 100 para 1 000 000 (ou
1 us) no campo respectivo da janela ModelSim XE. Inicie a simulação seleccionado a
primeira opção do sub-menu Simlate → Run →.

8. Utilizando o Zoom adequado verifique que as alterações de valor na sáıda led ocorrem
simultaneamente com as transições do flanco ascendente do relógio clk.

9. Para sair do simulador seleccione a opção File → Quit, voltado a aplicação do Project
Navigator da Xilinx.

3.5 Implementação do Circuito

1. Para realizar a implementação do circuito para a FPGA da Xilinx seleccione o circuito a
implementa (cir1) e faça um duplo click em Implementing Design. A ferramenta vai correr
uma série de programas e apresentando diversos relatórios na janela inferior.

2. Depois da ferramenta acabar, cada um desses relatórios pode ser analisado separadamente.
Por exemplo, para listar os relatórios produzidos pela ferramenta de colocação e interli-
gação (place and route) deve-se expandir a seguinte sequência de ramos (através de um
click no sinal �): Implementing Design → Place & Route
Para ver o relatório de interligação e colocação numa janela faça um duplo click em Place
& Route Report. Nesse relatório poderá verificar, por exemplo, o número de slices da
FPGA ocupados pelo circuito.
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3.6 Simulação Temporal do Circuito

A simulação temporal do circuito tem como objectivo simular o circuito tendo em conta todos
os atrasos existentes em cada um dos sinais do circuito. Estes atrasos resultam do mapeamento
do circuito em portas lógicas de uma dada tecnologia, com atrasos espećıficos, e também dos
atrasos introduzidos pelas interligações dessas portas (que pode ser muito significativo no caso
de uso da tecnologia FPGA).

Para esta simulação pode, e deve, ser usada a mesma bancada de teste que foi utilizada na si-
mulação comportamental. Pretende-se verificar que os atrasos introduzidos pela implementação
do circuito numa dada tecnologia não vão alterar a sua funcionalidade.

3.6.1 Simulação Final da Bancada de Teste

1. Seleccione a bancada de teste que deseja simular (cir1 tb.vhd) na janela Sources in
Project. Para realizar a simulação temporal faça um duplo click em Simulate Post-Palce
& VHDL Model.

2. Verifique se o circuito apresenta o comportamento adequado através do resultados apre-
sentados nas janelas criadas pelo simulador.

3. Verifique também que agora não é necessário inicializar a sáıda q do flip-flop, pois esta é
automaticamente inicializada pela FPGA.

4. Utilizando o zoom adequado observe que as alterações de valor na sáıda led deixaram de
ocorrer simultaneamente com as transições do flanco ascendente do relógio clk. Existe um
atraso (da ordem dos ps) que resulta do circuito estar a ser simulado com portas lógicas
de uma dada tecnologia.

5. Para sair do simulador seleccione a opção File → Quit, voltado a aplicação do Project
Navigator da Xilinx.

3.7 Programação do FPGA

Após verificação do correcto funcionamento do circuito através da simulação temporal do cir-
cuito, este poderá ser implementado na FPGA.

3.7.1 Criação de um Circuito de Topo

1. Cada circuito a ser programado na FPGA deve ter todas as entradas e sáıdas globais
associadas aos pinos correspondentes na FPGA e os buffers especiais de entrada e sáıda
que poderão ser necessários. Assim, crie um circuito para a programação da FPGA que
associa os sinais externos aos respectivos pinos, cria os buffers necessários e contém o
circuito a implementar.

2. Seleccione Project → Add Copy of Source. Seleccione o ficheiro VHDL fpga.vhd do disco
C: ou A:. Escolha o tipo de ficheiro VHDL como VHDL Module.

3. Faça um duplo click sobre o ficheiro que acabou de adicionar ao projecto e verifique que
o código VHDL está de acordo com a seguinte descrição:
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library IEEE;
library UNISIM;
use IEEE. STD LOGIC 1164 . al l ;
use IEEE. STD LOGIC ARITH. al l ;
use IEEE. STD LOGIC UNSIGNED. al l ;
use UNISIM. Vcomponents . al l ;

entity fpga is
port ( btn in : in s t d l o g i c ;

c l k i n : in s t d l o g i c ;
l ed out : out s t d l o g i c ) ;

end fpga ;

architecture Behavioral of fpga is

attribute loc : s t r i ng ; −− para assoc iar cada s i n a l externo
−− a um pino da FPGA

attribute loc of btn in : signal is ”p77” ;
attribute loc of c l k i n : signal is ”p80” ;
attribute loc of l ed out : signal is ”p71” ;

component c i r1
port ( botao : in s t d l o g i c ;

c lk : in s t d l o g i c ;
led : out s t d l o g i c ) ;

end component ;

signal c l k l o c a l : s t d l o g i c ;
signal b tn l o c a l : s t d l o g i c ;

begin

−− s i n a i s que necessi tam de b u f f e r s
CLK BUFFER : IBUFG

port map ( I => c l k i n , O => c l k l o c a l ) ;
BTN BUFFER : IBUFG

port map ( I => btn in , O => b t n l o c a l ) ;

−− o c i r c u i t o a implementar
I n s t c i r 1 : c i r 1

port map( botao => b tn l o c a l ,
led => l ed out ,
c lk => c l k l o c a l ) ;

end Behavioral ;
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4. Com o circuito de topo (fpga) seleccionado encontre na janela Processes for Current
Source o processo Generate Programing File. Sobre este processo e com o botão da direita
seleccione a opção Properties....

5. Na janela criada (Process Properties) escolha a entrada Startup Options e altere o valor
da entrada Start-Up Clock de CCLK para JTAG Clock. Seleccione OK para fechar a janela.

6. Faça um duplo click em Generate Programing File para executar todos os processos de
śıntese sobre o circuito de topo, incluindo a geração do ficheiro para a programação da
FPGA. Verifique os relatórios gerados por estes processos na janela inferior. Se não houver
erros a FPGA da placa de desenvolvimento pode ser programada.

3.7.2 Configuração da FPGA com o Circuito

1. Ligue a placa com a FPGA ao computador utilizado a porta paralela. Alimente a placa
da FPGA e verifique que o switch existente na placa está colocado na posição JTAG.

2. Expanda os ramos de Generate Programing File (através de um click no sinal�). Com o rato
sobre Configure Device (iMPACT) seleccione com o botão da direita a opção Properties....

3. Na janela Process Properties, altere o valor de Configuration Mode para Boundary Scan e
seleccione o ficheiro .bit correspondente ao circuito de topo (fpga.bit) na propriedade
Configuration Filename. Seleccione OK para fechar a janela.

4. Faça um duplo click em Configure Device (iMPACT) para iniciar o processo de configuração
da FPGA.

5. Depois de ter sido estabelecida a comunicação com a placa através da porta paralela na
janela criada (Untitle [Configuration Mode] - iMPACT) aparece o ı́cone de uma FPGA
da Xilinx. Certifique-se que sobre esse ı́cone se encontra o ficheiro .bit correcto para ser
carregado (correspondente à entidade de topo).

6. Sobre o ı́cone da FPGA seleccione com o botão da direita a opção Program... e depois
seleccione OK na janela Program Options. Após o carregar correctamente a configuração
para FPGA esta comporta-se de imediato como uma implementação do circuito projectado.

7. Verifique se o circuito funciona como pretendido.

4 Arquivar o Projecto

Para guardar o projecto sobre a forma de um arquivo ZIP deve-se primeiro eliminar os ficheiros
desnecessários do projecto seleccionado Project → Cleaup Project Files e só depois arquivar o
projecto com Projecto → Archive. Na directoria onde foi criado o projecto é criado um ficheiro
.zip com o mesmo nome do projecto e que pode ser copiado para diskette.

5 Projecto do 2o Circuito

Utilize os conhecimentos que adquiriu para projectar um circuito que utilizando um contador
divida o relógio de 50 Mhz para se obter um peŕıodo da ordem dos segundos.
Interponha esse circuito entre o pino de relógio da FPGA e a entrada de relógio do 1a circuito.
Para ter uma ideia de como fazer um divisor de relógio baseie o seu circuito na seguinte especi-
ficação VHDL:
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library IEEE;
use IEEE. STD LOGIC 1164 . al l ;
use IEEE. STD LOGIC ARITH. al l ;
use IEEE. STD LOGIC UNSIGNED. al l ;

entity c l o ck d iv is
port ( c l k i n : in s t d l o g i c ;

c lk out : out s t d l o g i c ) ;
end c l o ck d iv ;

architecture Behavioral of c l o ck d iv is
signal counter : s t d l o g i c v e c t o r (24 downto 0 ) ;

begin
process ( c l k i n )
begin

i f c l k i n ’ event and c l k i n = ’ 1 ’ then
counter <= counter + 1;

end i f ;
end process ;

c lk out <= counter ( counter ’ high ) ;

end Behavioral ;

6 Referências

Listam-se em seguida algumas formas de obter mais informação sobre śıntese de circuitos usando
este ambiente de śıntese da Xilinx.

• O caṕıtulo 6 do Xilinx Synthesis Technology (XST) User Guide que se encontra dispońıvel
na página da cadeira (em formato pdf).

• Consultar e utilizar os Language Templates que se encontram no ı́cone lâmpada da barra
de ferramenta do Project Navigator. Em particular os templates de VHDL para śıntese.

• Ler a documentação existente no menu de Help da ferramenta. Em Particular Help →
On-Line Documentation (em formato pdf).

$Id: trab1.tex,v 1.5 2003/03/07 18:13:26 pff Exp

CID/SID 2002/03 9


